【まだ続く】メモリ交換で復活したと思われた自作機、未だに変

こんばんは、しののめです。またこのネタかーいって感じなんですが、すみません。自分でもわけわからん状況になりつつあるので、自分用のメモ的な意味も込めて書き残させてください。

まず簡単に経緯を。

お久しぶりです! すっかり存在感が消えていますが生きてます! 身内の退院の目処がたたなくてもう毎日大変です。その結果しばらく鳴りを潜めてい...

22日にメイン機のビデオカードをRX570からRTX2060に交換しました。上の記事のとおり、当日はなんの問題もなく動作していました。

タイトルのとおりです。昨日RTX2060にパワーアップして何事もなく使えたよ~って書いたばかりですが! 今日起動しようとしたところロック画...

ところが翌日PCを起動しようとするとロック画面でフリーズ。やむなく強制終了するものの、以降メモリエラーのビープ音が鳴り、なにをしても起動しなくなります。

怒涛の連続更新。グラボ交換で起動しなくなった自作機ですが、なんやかんややってるうちに復活したので報告です。 結論から言うと原因はグラ...

そのさらに翌日。だめもとでメモリ1本で試したところまさかの起動成功。若干挙動が怪しかったのでRadeonのドライバを削除。その後は安定したように思われたため、メモリの相性問題だったということで終わる…はずでした。

で、やっと本日新しいメモリが到着。

買ったのはこちらのコルセアさん製メモリです。マザボの対応表にあって、かつASUSさんのB450マザーで正常使用している方を確認できたため選択。

無駄に緊張しつつ取り付けた結果は…

ビープ鳴らずに無事起動!!

勝った!って思いましたよ!

ただ、前のメモリはネイティブ2666Mhzでしたがこちらは定格2133Mhz。BIOSからメモリ内にある設定を読み込んであげないと2666では動作しないそうです。インテルだとXMPと呼ばれているものですね。呼び方共通だと思ってた…(恥ずかしい)。AMDの場合はマザーのメーカーさんごとに似たような独自機能があって、私が使っているASUSさんの場合はD.O.C.Pという名前らしい。設定はプルダウンメニューから選ぶだけなので簡単です。詳しくは後ほど。

で、無事に2666Mhz動作もできました。ゲーム動かしてもベンチぶん回しても非常に快調! これは完全に勝った! と、思っていたんですよ!!

ここで一旦夕食を挟むためPCをスリープにします。これがすべての始まりでした。

夕食の片付けを終えさぁ色々できなかった分頑張るかぁとPCの電源ボタンを押します。ファンが回ってLEDが光る…ここまでは正常。しかしモニターはノーシグナルです

電源の入れ直し、ケーブルの抜き差し等しても直らず。このPCにリセットボタンはないので、やむなく電源ボタン短押しでシャットダウンさせようとしました。しかしいくら待っても電源が落ちる気配はない…

またかよー! と思いながらしぶしぶ強制終了。これだけ頻繁に強制終了しているとメモリやらグラボやらよりストレージがだめになりそうで恐いです。

一旦メイン機はお休みさせて、サブ機でこの減少について調べ始めました。そして見つけたのは

  • RadeonからGeForceへの乗り換え後
  • DisplayPortを使っている(正確には変換コネクタを噛ませてます)
  • UEFIの各種ブートオプションがすべて有効

という条件が揃うと、スリープ復帰後同様の症状が見られるという事例。ただ、その情報が書かれている日付は古く、マザーボードが(現在からみて)かなり古い場合に起こる問題のようでした。

ただ、ブートオプション(という言い方が合っているのかは不明ですが、便宜上そう書きます)をすべてONにするのはMicrosoftさんもだめと言っているようなので、念の為確認。

見事すべて有効になっていました。

最初からこうだったのかCMOSクリア後になったのか、はたまたビデオカード交換前日にネット経由でBIOSアップデートしたときなのかは不明…とりあえず、Radeonの頃からモニター周りは全く同じで、同様の不具合は一度もありませんでした。となるとマザーとビデオカード固有の問題…? そろそろ頭が痛くなってきます。

とりあえず疑惑のDPを外してHDMI1本のシングルモニタ環境に(デュアルに慣れるときつすぎるんですが…)。ブート設定は全然わからないからCSMだけ無効に。念の為メモリ周波数をAUTOに戻して( D.O.C.P はそのまま。下げる分には問題ないかなと)OSを起動しました。何事もなくWindowsが立ち上がりほっとするのもつかの間…ブラウザを立ち上げて適当なページを開いた途端まさかのブルースクリーンが出ました。

Windows10歴2年以上、5台以上で初めてですよ。7までは結構頻繁に見ていましたね…そのくらい安定したOSだと思っていたのでこれにはびっくり。エラーコードは「UNEXPECTED_KERNEL_MODE_TRAP」で、検索してみるとドライバ関係らしい? 今年組んだものだから大丈夫かなと思ったんですが、確認せずにやったのは間違いでした。

青画面には自動で再起動するとあるものの30分以上待っても一向にする気配なし。%表示すら出てきません。これは本格的にやばいぞと思いつつも強制終了。再び電源を入れるとファンが一瞬回ってすぐに停止、そして初めて聞く単音×3のビープ音が…! 文章じゃ伝わらないと思いますがこのときの絶望感やばかったです。私がおろおろしている間にその動作を数回繰り返した後、正常なPOST音がしてマザーのロゴが。とりあえずBIOSは生きていたので、 速攻CSMを有効に戻しました。ここらへん詳しくない人は触るべきじゃないです。本当に。

次はセキュアブートを切ってみようと思ったんですが、グレーアウトしていて変更不可。どうやらキーの変更?をしなければ切り替えられない模様。しかも場合によってはOSのクリーンインストールをしなきゃ再び有効に戻せないという記事を見て、これを無効にするのは諦めました。リスクが大きすぎる。なので直接影響がなさそうなFast Bootだけ無効に。メモリ速度はいじらず定格のままOSを起動させた…のが今の状態です。

今の所OS上の動作に問題はありません。スリープは怖くて試せていないんですが再起動とシャットダウンは正常に行えて、DISM.exeとsfc /scannow、メモリ診断等回してみても異常は一切出てきません。タスクマネージャーで見るとメモリは2133で動いています。

また不安定になるくらいならメモリ速度はこのままでいいです。だけどスリープとデュアルモニターが使えないのはすごく困ります。やっぱりショップに持って行って一度見てもらったほうが良さげですね…相性ではなく私の組み方が悪い可能性もありすぎるので。ピン曲がりとか金属部品との接触とかピン曲がりとか…。

ぐだぐだですが、自作機復活にはもう少し掛かりそう、って記事でした。また変化があったら書くと思います。

Ci-enはもう絶対間に合わないので今月の新作はなしです。楽しみにしていらっしゃる方がいたらごめんなさい。一応過去の素材の再配布を予定しているので、そちらで我慢していただければと思います。

それでは。

シェアする

  • このエントリーをはてなブックマークに追加

フォローする